
Tested Material Used To SPLK-2001 Test Engine Exam Questions in here [Oct-2021]
Penetration testers simulate SPLK-2001 exam PDF
NEW QUESTION 34
When the search/jobs REST endpoint is called to execute a search, what can be done to reduce the results size in the results? (Select all that apply.)
- A. Truncate the data, using selective functions.
- B. Remove unneeded fields.
- C. Summarize data, using analytic commands.
- D. Use a generating search.
Answer: B,D
NEW QUESTION 35
Which of the following is a way to monitor app performance? (Select all that apply.)
- A. Using the Monitoring Console.
- B. Using the storage/collections/config REST endpoint.
- C. Using Splunk logs.
- D. Using the search job inspector.
Answer: A,C
NEW QUESTION 36
How can indexer acknowledgement be enabled for HTTP Event Collector (HEC)? (Select all that apply.)
- A. No need to do anything, it is turned on by default.
- B. When a new HEC token is created in Splunk Web, select the checkbox labeled "Enable indexer acknowledgement".
- C. When a REST request is sent to create a token, the property for indexer acknowledgement must be set to
1. - D. When the Global Settings for HEC are updated in Splunk Web, select the checkbox labeled "Enable indexer acknowledgement".
Answer: B,D
NEW QUESTION 37
Data can be added to a KV store collection in which of the following format(s)?
- A. JSON, XML, CSV
- B. JSON, XML
- C. JSON
- D. JSON, XML, CSV, TXT
Answer: C
NEW QUESTION 38
Given the following two files defining app navigation, which navigation options will be displayed to the end user? (Select all that apply.)
$SPLUNK_HOME/etc/apps/app_name/default/data/ui/nav/default.xml
<nav search_view="search" color="#65A637">
<view name="search" default='true' />
<view name="datasets" />
<view name="reports" />
<view name="dashboards" />
</nav>
$SPLUNK_HOME/etc/apps/app_name/local/data/ui/nav/default/xml
<nav search_view="search" color="#65A637">
<view name="search" default='true' />
<view name="datasets" />
<view name="dashboards" />
</nav>
- A. Reports
- B. Dashboards
- C. Datasets
- D. Search
Answer: A,C
NEW QUESTION 39
Which HTTP Event Collector (HEC) endpoint should be used to collect data in the following format?
{"message":"Hello World", "foo":"bar", "pony":"buttercup"}
- A. data/inputs/http
- B. services/collector
- C. services/collector/raw
- D. data/inputs/http/{name}
Answer: C
NEW QUESTION 40
Which files within an app contain permissions information? (Select all that apply.)
- A. metadata/default.meta
- B. metadata/local.meta
- C. local/metadata.conf
- D. default/metadata.conf
Answer: A,D
NEW QUESTION 41
Which Splunk REST endpoint is used to create a KV store collection?
- A. /storage/kvstore/create
- B. /storage/collections
- C. /storage/kvstore/collections
- D. /storage/collections/config
Answer: B
NEW QUESTION 42
Which of these URLs could be used to construct a REST request to search the employee KV store collection to find records with a rating greater than or equal to 2 and less than 5?
- A. 'http://localhost:8089/servicesNS/nobody/search/storage/collections/data/ employees?query={%22rating%22:{%22$gte%22:2}},{%22$and%22},{%22rating%22:{%
22$lt%22:5}}}
&output_mode=json' - B. 'http://localhost:8089/servicesNS/nobody/search/storage/collections/data/ employees?query={$and:[{rating:{$gte:2}},{rating:{$lt:5}}]}
&output_mode-json' - C. 'http://localhost:8089/servicesNS/nobody/search/storage/collections/data/ employees?query={%22$and%22:[{%22rating%22:{%22$gte%22:2}},{%22rating%22:{%
22$lt%22:5}}]}
&output_mode=json' - D. 'http://localhost:8089/servicesNS/nobody/search/storage/collections/data/ employees?query={$and:[{rating:$gte:2}},{rating:{$lt:5}}]}
&output_mode=json'
Answer: A
NEW QUESTION 43
Which of the following are requirements for arguments sent to the data/indexes endpoint? (Select all that apply.)
- A. Be url-encoded.
- B. Specify the datatype.
- C. Include the bucket path.
- D. Include the name argument.
Answer: B,D
NEW QUESTION 44
Which of the following are types of event handlers? (Select all that apply.)
- A. Form input
- B. Visualization
- C. Set token
- D. Search
Answer: A,B
NEW QUESTION 45
A user wants to add the token $token_name$ to a dashboard for use in a drilldown. Which token filter encodes URL values?
- A. $token_name|u$
- B. $token_name|n$
- C. $token_name|h$
- D. $$token_name$$
Answer: A
NEW QUESTION 46
Which of the following are valid parent elements for the event action shown below? (Select all that apply.)
<set token="Token Name">sourcetype=$click.value|s$</set>
- A. <change>
- B. <drilldown>
<condition> - C. <change>
<condition> - D. <eval>
Answer: C,D
NEW QUESTION 47
Log files related to Splunk REST calls can be found in which indexes? (Select all that apply.)
- A. _thefishbucket
- B. _blocksignature
- C. _audit
- D. _internal
Answer: C,D
NEW QUESTION 48
Given a dashboard with a Simple XML extension in myApp, what is the XML reference for the file myJS.js located in myOtherApp in the location shown below?
$SPLUNK_HOME/etc/apps/myOtherApp/appserver/static/javascript/
- A. <dashboard script="myOtherApp:javascript/myJS.js">
- B. <dashboard script="myJs.js">
- C. <dashboard script="myOtherApp:appserver/static/javascript/myJS.js">
- D. <dashboard script="myOtherApp/myJS.js">
Answer: B
NEW QUESTION 49
After updating a dashboard in myApp, a Splunk admin moves myApp to a different Splunk instance. After logging in to the new instance, the dashboard is not seen. What could have happened? (Select all that apply.)
- A. The admin deleted the myApp/local directory before packaging.
- B. User role permissions are different on the new instance.
- C. Changes were placed in: $SPLUNK_HOME/etc/apps/search/default/data/ui/nav
- D. The dashboard's permissions were set to private.
Answer: B,D
NEW QUESTION 50
Which of the following statements describe oneshot searches? (Select all that apply.)
- A. Can use auto_cancel to set a timeout limit.
- B. Stream all results upon search completion.
- C. Can specify csv as an output format.
- D. Are always executed asynchronously.
Answer: B,C
NEW QUESTION 51
Which of the following are ways to get a list of search jobs? (Select all that apply.)
- A. Use Splunk REST to query the /services/search/jobs endpoint.
- B. Access Activity > Jobs with Splunk Web.
- C. Use Splunk REST to query the /services/saved/searches endpoint.
- D. Use Splunk REST to query the /services/search/sid/results endpoint.
Answer: A,B
NEW QUESTION 52
What must be done when calling the serviceNS endpoint?
- A. Authenticate with the user of the required context.
- B. Pass the user and app context in the request payload.
- C. Authenticate with an admin user.
- D. Specify the user and app context in the URI.
Answer: D
NEW QUESTION 53
Which of the following options would be the best way to identify processor bottlenecks of a search?
- A. Using the Splunk Monitoring Console.
- B. Using the REST API.
- C. Using the search job inspector.
- D. Searching the Splunk logs using index=" internal".
Answer: A
NEW QUESTION 54
Which of the following will unset a token named my_token?
- A. <unset>$my_token$</unset>
- B. <unset token="my_token"></unset>
- C. <set token="my_token">false</token>
- D. <set token="my_token">disabled</set>
Answer: B
NEW QUESTION 55
To delete the record with a _key value of smith from the sales collection, a DELETE request should be sent to which REST endpoint?
- A. /storage/collections/data/sales/smith
- B. /storage/kvstore/collections/sales/smith
- C. /storage/collections/sales/smith
- D. /storage/kvstore/data/sales/smith
Answer: A
NEW QUESTION 56
There is a global search named "global_search" defined on a form as shown below:
<search id="global_search">
<query>
index-_internal source-*splunkd.log | stats count by component, log_level
</query>
</search>
Which of the following would be a valid post-processing search? (Select all that apply.)
- A. search log_level=error | stats sum(count) AS count by component
- B. stats sum(count) AS count by log level
- C. | tstats count
- D. sourcetype=mysourcetype
Answer: A,B
NEW QUESTION 57
Which of the following are security best practices for Splunk app development? (Select all that apply.)
- A. Store passwords in clear text in .conf files.
- B. Manually test application with the controls listed in the OWASP Security Testing Guide.
- C. Implement security in software development lifecycle.
- D. Use a dynamic scanner such as OWASP ZAP to scan web application components for vulnerabilities.
Answer: B,D
NEW QUESTION 58
......
Authentic Best resources for SPLK-2001 Online Practice Exam: https://www.pass4training.com/SPLK-2001-pass-exam-training.html
Get the superior quality SPLK-2001 Dumps with explanations waiting just for you, get it now: https://drive.google.com/open?id=1dTblV51NvtEnSTDXcuW_mZ-f7jIhcarM

